Rating:        Based on 17 ratings
Reviewed:  16 reviews
Downloads: 85504
Released: May 26, 2015
Updated: May 26, 2015 by jbrinkman
Dev status: Stable Help Icon

Recommended Download

Application 7.4.1 - New Install
application, 68308K, uploaded May 25 - 18147 downloads

Other Available Downloads

Application 7.4.1 - Version Upgrade
application, 48545K, uploaded May 25 - 6807 downloads
Source Code 7.4.1 - Source Code
source code, 68203K, uploaded May 25 - 7098 downloads
Application 7.4.1 - Symbols Files
application, 2313K, uploaded May 25 - 677 downloads
Application 7.4.1 - Web Platform Installer
application, 68385K, uploaded May 25 - 51275 downloads
Application 7.4.1 - Core API Help File
application, 138729K, uploaded May 25 - 1500 downloads

Release Notes

Major Highlights

  • Fixed race condition which could cause errors during file upload
  • Fixed issue where country profile property can cause registration to fail
  • Fixed issue where calendar control breaks in Arabic language
  • Fixed issue where Italian Language pack causes error on Host Settings
  • Fixed issue where Twitter Provider fails to create unique DNN login names
  • Fixed issue where creating a social group can fail in the "All Roles" mode
  • Fixed issue where custom url providers can't be disabled
  • Fixed issue where upgrades can fail if portalsettings has invalid values
  • Fixed issue where permissions can't be applied to a shared module
  • Fixed issue where url rewriting is broken for non-2 letter culture codes
  • Fixed performance issue where missing page doctype causes excessive file lookups
  • Fixed performance issue where testing for local URIs causes slow DNS lookups
  • Fixed issues where removing large number of unauthorized users would fail
  • Fixed issue where RazorHost did not follow standard Razor Engine behavior
  • Fixed issue where JavaScript library version number cannot hold full value for some libraries
  • Fixed issue where JavaScript libraries don't work in cached modules
  • Fixed issue where JavaScript library API doesn't immport full dependency tree
  • Fixed issue where 404 page was included in the sitemap
  • Fixed issue where en-us systemlocale was hardcoded in PortalSettings API
  • Fixed performance issue where some HttpModules were executed for static file requests
  • Fixed issue where user registration can fail with long passwords
  • Fixed issue where Country properties were returning numeric id rather than value
  • Fixed issue where browser language detection fails
  • Fixed issue where URLs are not exported correctly in page content
  • Fixed issue where switching languages removes the query string parameters
  • Added new Security Analyzer module
  • Fixed caching issues with multi-language portalsettings

Security Issues

  • Fixed account creation issue in install wizard (critical)
  • Fixed request forgery issue in file upload component (low)
  • Fixed information leakage issue for file existence (low)
  • Fixed information leakage issue for installed version (low)

Community Contributors

  • Jan Jonas (18)
  • Brian Dukes (10)
  • Ernst Peter Tamminga (7)
  • Sebastian Leupold (4)
  • Bogdan Litescu (3)
  • redhound (2)
  • Vicenç Masanas (2)
  • Robrecht Siera (2)
  • Oliver Hine (2)
  • Kornelis Pieters (1)
  • Mitchel Sellers (1)
  • Stefan Cullmann (1)
  • Evan Smith (1)
  • Morteza Kermani (1)
  • Peter Donker (1)
  • Serge van der Ven (1)
  • Brad Bamford (1)
  • Stephen Lim (1)
  • Richard Howells (1)
  • Willwh (1)
  • JBradley (1)
  • Sacha Trauwaen (1)

NOTE: Please log any issues you may find to http://dnntracker.atlassian.net

Reviews for this release

Smooth upgrade from 7.3.2 to 7.4.1. Existing site has multiple 3rd party modules and skins (SunBlogNuke, DNNArticle, DNNVista skin, metaPost and others). Everything works!!!
by Samuelphung on Sep 2 at 5:48 PM
Death loop during upgrade process. Can't upgrade or log in. /login.aspx returns error page. Unrecoverable. Renamed install directory, deleted all ol desktop modules. Site runs for a while, no way to log in or complete upgrade process. Been using DNN for nearly 10 years, scratching my head.
by TestShoot on Aug 26 at 9:58 PM
after the upgrade, a custom registration field of the list data type is no longer populated. The dropdownlist shows fine but is empty. This prevents new user from registering in our site. Any thoughts on how to solve this? Our site is in Spanish.
by chernandez on Jul 27 at 7:49 PM
after the upgrade, my site has lost all the custom skins, all pages are messed up. any idea?
by CrystalLi on Jul 26 at 11:19 PM
Will 7.4.1 be last release in 7.x.x serie?
by redhound2 on Jul 16 at 8:57 AM
No. We are currently working on 7.4.2.
Reply by DotNetNuke (Coordinator) on Jul 16 at 12:22 PM
After the upgrade error: The page cannot be displayed because an internal server error has occurred. Help.
by mns777 on Jul 10 at 6:16 PM
If you use the AD Authenticaton, do not upgrade... it doesn't work properly. User profile fields seem to get crossed
by billbayjr on Jul 7 at 9:19 PM
Update from 7.2.2 to 7.4.1 worked really good, except one Bug in our Module with the Cachebacle Attribute which isnt working as before [Cacheable("TABLENAME", CacheItemPriority.Default, 20)]
by comperioch on Jun 30 at 12:49 PM
the new install is much better, especially performance improved (installed on test environment) but the upgrade install from 7.3.4 to 7.4.1 is not giving any success. Tried several times on production server with all prerequisites (.net 4.5, sql 2012..) and i have no results, the only successful time doesnt permit host access. All other users can login successfuly apart from host. I had my 3rd party modules uninstalled and ran the TurboUnSchemaxxx.sql script before upgrading. I wonder what would be causing issue
by olpoc on Jun 28 at 2:13 PM
upgraded 7.3.4 to 7.4.0 and then 7.4.1 with no issues in QA. Installer and site are solid and all of our test cases passed.
by ScottBuchanan on Jun 9 at 2:34 AM
7.3.4 to 7.4.1 no good.. broke host/admin menu, dropdowns won't work under host settings, can't even open the logs on the Event Viewer page.. when I click on them nothing happens.. My site was working JUST FINE before.. I don't understand why we have to deal with this upgrade gamble almost every time.. I didn't even use my site much for the past few months.. didn't change anything.. didn't install new modules.. how can it break from an upgrade when it was working fine before??
by apluspcct on Jun 3 at 4:25 PM
sorry to hear about your upgrade issues - so far we haven't had many reports of users with issues and there have been 11k+ downloads. That suggests it may be site specific e.g. wrong prerequisites (i.e. not .net 4/sql 2008+), or else a site has ran an unsupported 3rd party tool (such as turbodnn), or sometimes something skin or module specific. I recommend you log this at support.dnnsoftware.com with as much detail as possible.
Reply by cathalconnolly (Coordinator) on Jun 12 at 2:45 PM
There are many fixes and that is good but some core items have stopped working. I have described them below and in JIRA I cannot save page settings at Admin > Page Settings https://dnntracker.atlassian.net/browse/DNN-7050 HTML Icon is not saved when using drag-and-drop function though the "Upload File" buttons does work https://dnntracker.atlassian.net/browse/DNN-7051
by LennardvD on Jun 2 at 8:49 AM
Much better! A number of the items that caused me much grief in 07.04.00 have been addressed. Export of site templates and url error on site creation have both been addressed. Thank you!
by ggiordan on Jun 2 at 1:10 AM
Device Detection is currently unavailable. DotNetNuke.Services.Exceptions.ModuleLoadException: Could not load file or assembly 'FiftyOne.Foundation, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) ---> System.Web.HttpParseException: Could not load file or assembly 'FiftyOne.Foundation, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) ---> System.Web.HttpParseException: Could not load file or assembly 'FiftyOne.Foundation, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) ---> System.IO.FileLoadException: Could not load file or assembly 'FiftyOne.Foundation, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Excepti
by utmar on May 29 at 2:58 PM
this release uses the version of FiftyOne.Foundation.dll (found in bin/providers). The error message suggests that your site is trying to use an old version. The most likely cause is that you do not have correct permissions (i.e. you don't have read, write and modify permissions on web.config - or else that web.config is read only), so the provider updated the dll but when it tried to update the web.config to set the assembly binding redirect to point to the newer version it failed. Please check your permissions, and update any assembly binding redirects for that dll
Reply by cathalconnolly (Coordinator) on Jun 1 at 11:49 AM
Upgrade of a fresh 7.4 site went well. Still scratching my head why the long reported [Tab.DigitalAssetsManagement.Content.Text] text on the File Manager hasn't been fixed when it was the last remaining issue in DNNtracker before release. Will review any bugs I had in 7.4 against this, but so far no errors. UPDATE: Thank you, Cathal, for the response. I just upgraded three more sites with no issues to report.
by TPPerlman on May 28 at 12:02 PM
It was reported as cannot reproduce, but then later we found it was an issue only with the blank template (i.e. not the standard template). By the time it was discovered the resx was frozen (it get's frozen before the end as it needs translated into the 5 supported languages). I've assigned it to 7.4.2 to ensure it gets fixed.
Reply by cathalconnolly (Coordinator) on May 26 at 10:32 PM
Upgraded 1 site on Azure with no issues... upgraded the 2nd (PokerDIY) and the installer failed halfway.. after a bit of a panic I managed to get it going again and all is well - fairly painless upgrade... still waiting patiently for the latest JSON and Web API 2 - messaging is broken on my site until then...
by PokerDIY on May 27 at 8:49 AM
FYI DNN 8 will have updated newtownsoft json and WebAPI versions
Reply by cathalconnolly (Coordinator) on May 27 at 3:10 PM