Rating:        Based on 23 ratings
Reviewed:  21 reviews
Downloads: 49799
Released: Aug 13, 2013
Updated: Aug 13, 2013 by jbrinkman
Dev status: Stable Help Icon

Recommended Download

Application 7.1.1 - New Install
application, 46910K, uploaded Aug 13, 2013 - 11440 downloads

Other Available Downloads

Application 7.1.1 - Version upgrade
application, 33701K, uploaded Aug 13, 2013 - 5381 downloads
Source Code 7.1.1 - Source Code (New Install + Source Code)
source code, 121238K, uploaded Aug 13, 2013 - 3978 downloads
Application 7.1.1 - Symbol Files
application, 2053K, uploaded Aug 13, 2013 - 549 downloads
Application 7.1.1 - Web Platform Installer
application, 46977K, uploaded Aug 13, 2013 - 27052 downloads
Documentation 7.1.1 - Core API Help File
documentation, 41739K, uploaded Aug 13, 2013 - 1027 downloads
Application 7.1.1 - Web Platform Installer - Pro
application, 67870K, uploaded Aug 13, 2013 - 372 downloads

Release Notes

Major Highlights

  • Fixed issue where vanity URL was not working correctly in FireFox
  • Fixed issue where default Friendly URL setting was missing for the doNotRewriteRegex
  • Fixed issue where language URLs were not working
  • Fixed issue where adding a new page resulted in an error message
  • Added the ability to define a standard prefix to vanity URLs
  • Fixed issue where the unauthenticated role permissions were not being applied
  • Fixed issue where password strength meter was missing for sites upgraded to 7.1
  • Fixed issue where the Search Admin was missing a resx file in the mobile site template
  • Updated RadControls for ASP.Net Ajax to the Q2 2013 release
  • Fixed issue where hard-deleting a user resulted in an error
  • Fixed issue where localization would stop working
  • Fixed issue where progress bar does not show any progress in the Digital Asset Manager
  • Fixed issue where removing a custom page URL causes a redirect to the home page
  • Fixed issue where language aliases are not created when importing a site with content localization
  • Fixed issue where upgrades from 6.1.5 would cause numerous error log entries regarding potentially dangerous request
  • Fixed issue where disabling anonymous authentication with AD provider installed causes 404 error

Security Fixes

  • Fixed potential reflective xss issue
  • Fixed issue where malformed html may allow XSS
  • Fixed issue that could lead to redirect 'Phishing' attack

Updated Modules/Providers


  • Languages Module


  • None

Reviews for this release

After I completed Installation, it popped a window with "Server Error 404 - File or directory not found", and when I clicked any page, it displayed the same error. Could anyone email me a fix as I want to get rid of it. Thanks in advance
by eissacreationsltd on Nov 3, 2013 at 12:47 AM
Two new installs and three updates from v6.2.7 without problems. My sites may be a little simples, but five sites without problem is a good news for me.
by EduAime on Sep 22, 2013 at 10:00 PM
This as a fresh install sadly does not work. If you are having trouble and getting 404 errors then check your web.config file and change your <modules tag to the following: <system.webServer> <modules runAllManagedModulesForAllRequests="true"> This will most likely fix you up if you are running IIS7.
by ryandoom on Sep 17, 2013 at 1:45 PM
Looks great! However it is not functional if the edit button doesn't work. Spent 2 hours scouring google and rebuilding the site twice and rebooting the server. Still cannot work on version 7.01.01. I must go backwards (Which I hate) and get a project started.
by rmarable on Sep 17, 2013 at 1:25 PM
very good !
by mydnn on Sep 13, 2013 at 2:08 PM
After I completed Installation, it popuped a window with "Server Error 404 - File or directory not found.". When I clicked any page, it displayed the same error.
by joshuabright on Sep 12, 2013 at 6:38 AM
I must change my review. I don't know about updating installation still have some issues but with a few fixes it works fine :) Good release.
by vladakg85 on Sep 8, 2013 at 5:06 PM
Upgrade from 7.1 required an update to Telerik.dll and fix to the web.config for Telerik version. Also receive error: Could not load type 'DotNetNuke.Modules.DigitalAssets.Edit'. Had to delete edit.ascx to fix. New Install got a 500 server error. To fix it I changed my web.config from urlFormat="advanced" to urlFormat="humanfriendly". "Browserfriendly" also works, but not "advanced".
by kewlgeek on Sep 3, 2013 at 4:24 PM
Not upgrading from 7.0.1. NOT a stable release,
by CodePlexUsermax on Sep 3, 2013 at 10:23 AM
Breaks Lotus skin web sites. (one of the most popular in the store). Issues with jquery references failing and hence any jquery driven UI for IE 10 on Windows 8.
by JamieClayton on Aug 30, 2013 at 9:50 AM
The upgrade ran fine but now we can no longer edit pages. When we click on Page settings from the edit menu we get the yellow screen of death saying: Server Error in '/' Application. Object reference not set to an instance of an object. Please help!
by syb on Aug 29, 2013 at 4:45 PM
Upgraded from DNN 7.0.5 and now no one can post on their own Journals
by PokerDIY on Aug 28, 2013 at 9:04 AM
ARRRRGH why all the time I give one different error.... Manually upgrade a 7.0.0 release Copy all the files , I go to www.mywebsite/install/install.aspx white screen!!! nothing appear! Ok and now, whow my home page isn't accessible!!! :(
by rmartin1977 on Aug 26, 2013 at 2:39 PM
Upgraded my site and although it said process was finished successfully and there is not message in the log, my whole website was trashed after that. When clicking on "Visit website", it goes back to the "/Install/UpgradeWizard.aspx" page. My home page is not accessible any longer. Had to revert to the backup.
by thercy on Aug 23, 2013 at 8:56 AM
Upgraded one site and it went well. Another site was a total disaster. The menu items that should be visible to unauthenticated users do not drop down. At least the modules are now visible to unauthenticated users...but the child menu items are not. I think I logged it. I'd do it again the new log system doesn't send me my password and doesn't take the password I'm pretty sure is correct.
by goombamd on Aug 23, 2013 at 3:50 AM
Great upgrade with many useful new features. I ran into 2 major problems when upgrading. The first one was caused by old module install-files left in the "install/module" folder. This folder should be empty before upgrading. The second problem was that I have removed the ProfessionalPreview-modul. The upgrade script has a dependency on that one. I needed to install it before the upgrade would work
by winsider on Aug 21, 2013 at 1:22 PM
The installer wont even run.
by nxcs on Aug 21, 2013 at 5:12 AM
Upgraded from 6.2 to 7.1.1 for my production sites with no issues, except one minor issue. User registration didn't work anymore. Fortunately there's an easy fix for this, took me a while to find out. Goto website settings >> page settings >> set the registration page pointer to --nothing selected--. This will enable the new DNN7 popup registration form. Besides this, solid release!
by jjk1977 on Aug 20, 2013 at 8:26 PM
I have just done an upgrade and it works with no issues. The new installation however has issues. it gets stuck on 90% (SuperUser Creation).
by patsoncc on Aug 15, 2013 at 10:32 AM
Not quite ready for prime time. Upgrade froze after 26% and my installation was trashed after that. Had to go back to latest backup.
by jangarella on Aug 14, 2013 at 11:38 PM
Install wizard wouldn't accept Super User credentials to install upgrade from DNN 7.1.0 to DNN 7.1.1. Reverted to backup.
by mayaco on Aug 14, 2013 at 3:49 PM